Follow

Is there software for MAC?


Yes, all products that use the Mionix HUB (v1.5 or later) software are compatible with MAC.

For anything below v1.5, you can find the downloads in the link below.

Software & Firmware page

*note our older Castors that come pre-bundled with v1.44 need to be updated

Was this article helpful?
1 out of 2 found this helpful
Have more questions? Submit a request

Comments